Player Resource Consortium

 

Author Topic: Commoner?  (Read 3595 times)

0 Members and 1 Guest are viewing this topic.

April 13, 2010, 03:38:24 PM

I was wondering if the Commoner (NPC) base class might ever see the light of day. Purely for roleplaying and stuff. It obviously wouldn't be for the powergamer. For example, you could play the poor, weak farmer girl that decides to embrace adventure after discovering she can wield spellfire. Or a miller, having lost his family in times of war, decides to make a demonic pact with Baalzebul.

It's not a strong argument for adding another base class, but I'm hoping it would take so little effort to create that that won't really matter.

http://www.dandwiki.com/wiki/SRD:Commoner


April 13, 2010, 09:43:45 PM
Reply #1
  • Developer
  • *****
  • Posts: 1439
  • Karma: +27/-0
  • Gender: Male
    • View Profile

I've never tried this, but I think you can enable commoner with a simple 2da edit:
extract classes.2da form prc_2das.hak and open it in notepad
find commoner class (row 20) and set 1 in 'PlayerClass' column. This should do the trick and you should be able to select commoner during level up.


April 14, 2010, 02:30:45 PM
Reply #2

I will check it out once I get home, thanks. :)


April 14, 2010, 04:55:38 PM
Reply #3

I extracted, edited the file and put it back, but the class doesn't appear in the character editor.


April 15, 2010, 02:47:08 PM
Reply #4

I just noticed I do get to select it during levelup, like you said. Any chance it can be made to activate in the prc character creator?


April 15, 2010, 08:50:21 PM
Reply #5
  • Developer
  • *****
  • Posts: 1439
  • Karma: +27/-0
  • Gender: Male
    • View Profile

I think you also need to change the value in 'XPPenalty' column to 1, but I haven't tested that.

By Character Creator you mean the one in Java or ConvoCC?
« Last Edit: April 15, 2010, 08:51:25 PM by xwarren »


April 16, 2010, 09:01:16 AM
Reply #6

I'm only aware of the one in Java. That's the one I'm using.

Testing the other column thing now..


April 16, 2010, 09:15:36 AM
Reply #7

This is kind of weird. I used TlkEdit yesterday and it worked. Today I can extract the 2da and reimport an edited version, but TlkEdit won't save the hak. It simply states that the file couldn't be saved, very odd.

I'm using Windows Vista. Is there anything else that will do the job of importing the new 2da?
« Last Edit: April 16, 2010, 09:17:34 AM by azenmin »