Player Resource Consortium

 

Author Topic: [Resolved] JavaCC not finding 2das  (Read 5569 times)

0 Members and 1 Guest are viewing this topic.

June 15, 2012, 01:08:04 PM

I started out by opening the manual and reading through the install instructions before trying anything, and while I'm pretty certain I haven't missed a step, I think the solution has to be pretty simple.


Preramble:

I'm using PRC 3.5, and JavaCC 1.8. I've also copied the resources for Project Q 1.4 and CEP 2.4a into my NWN install -- which by my understanding shouldn't have any effect on the PRC install. I downloaded everything everything yesterday.

I also downloaded the PRCQ merge and copied the files into NWN, then ran the PRC updater to patch the OC with PRC + Q. I'm not completely certain I did that step correctly, but I believe I followed the readme properly.

I'm using Java build 1.6.0_27-b07 and NWN+SoU+HotU 1.69 - Complete Edition from Gamer's Gate on Win 7 x64.

I have the JavaCC setup to use the haks as described in the directions - using the hak files:
prc_2das.hak
prc_race.hak
prc_textures.hak

and the tlks:
Custom - prc_consortium.tlk
Default tlk


Onto the issue:

I'm having an issue with the Characters Creator throwing up an error and crashing from not finding certain 2da files. The first time it complained about not find portraits.2da. This occurred even with vanilla NWN gender/race combos. (Male/Human specifically.)

So, I did some browsing around online and in these forums, and found nothing. I opened up everything (search utility) and checked and portraits.2da didn't exist, but I had a file called 2dasource.zip in the root NWN directory. (No 2da files in any subfolder of my NWN install, though.)

So after some googling, PRC manual scouring, and finally resorting to an educated (lucky) guess , I dropped portraits.2da into the portraits subfolder that the JavaCC directions had me create. That resolved it for the portraits.

I was now able to progress through choosing a class, but when I get to packages I receive a similar error. Upon choosing a package (I've tried different classes/packages), the CC spits out an error about being unable to find the relevant Pack with "FatalError - <Packname> not found. Your Data might be corrupt." Since the pack names correspond with more 2da filenames in the 2dasource.zip, I assume it's more of the same.

However, I have no idea where these 2da files should actually be or if there's something else creating this issue and futzing around with shoving 2das in various folders would just cause more harm than good. As I mentioned above, I've tried searching, not just in these forums, but also via google for information on this problem and on where the 2da files should properly be.

My results to this have been fairly limited or end at dead sites. As you know, nwn.bioware is gone (along with my account and a set of my old NWN keys, which I'd also lost the paper slips for - GRRRRRR). Nwn.wikia.com has some interesting info on the 2das, but I'm only finding that the original 2das should supposedly be packed other files and not be needed except for haks. And for the most part, other results are for NWN2 or completely irrelevant.


So, in summary:

I haven't played NWN in years and am really keen on playing with some of the new content and reading about the PRC has me amped; however the JavaCC is complaining that I don't have all the 2da files and crashing. Can someone help me fix this?

Thank you.
« Last Edit: June 18, 2012, 09:15:34 PM by MadPaladin »


June 15, 2012, 03:43:22 PM
Reply #1
  • Developer
  • *****
  • Posts: 1439
  • Karma: +27/-0
  • Gender: Male
    • View Profile

Portraits.2da and package files are not distributed with PRC - they are found in base game resources (*.bif files). Coult you double check your JavaCC settings (especially panth to NWN directory)?


June 15, 2012, 06:03:06 PM
Reply #2

Positive. I re-checked that multiple times. I copied and pasted the directories, and the JavaCC loads up and gets all the way to package selection -- I doubt this would happen if I had it pointed to the wrong location.

Here's a couple screenshots, maybe I'm failing laughably and am just blind to it. They're greyscale gifs to reduce filesize.

[ Guests cannot view attachments ]

[ Guests cannot view attachments ]

Is it possible that the bif file is corrupted? If it's 2da.bif, I see that in the data subdirectory alongside a slew of other bifs. I assume I could unpack it and check the contents of the 2da. I'm not quite certain where I'd find the unpacker, though. [Edit - More accurately, I'm not sure what a good unpacker is, but as far as where, I'll try the NWVault and return here with further questions.]

Thank you for your assistance.
« Last Edit: June 15, 2012, 06:07:57 PM by MadPaladin »


June 15, 2012, 06:35:30 PM
Reply #3
  • Developer
  • *****
  • Posts: 1439
  • Karma: +27/-0
  • Gender: Male
    • View Profile

Yes, it is possible that bif file got corrupted. My 2da.bif is exactly 2115713 bajts (NWN 1.69). Google NWN Explorer and check if you can open portraits.2da from the bif.


June 15, 2012, 08:15:44 PM
Reply #4

The filesize and opening with NWN Explorer both seem to check out. Final line of portraits.2da within the bif is 565 Rakshasa_f_ 4 20 **** 0 **** .

As it's apparently not a simple issue, I'll go ahead and try a full reinstall and see if that resolves it.


June 16, 2012, 05:51:59 PM
Reply #5

I believe I've resolved the issue. After reinstalling, and copying the PRC files into the NWN folder, I still had the problem. This time, however, I tried loading up NWN and I created a character within the game. Note that I haven't patched the OC with the PRC, this time. I had on my previous install, however.

After creating a character and loading the first module, I exited and tried again and the JavaCC seems to work now.

I'm not sure if this has to do with generating a character or loading the campaign for the first time. Regardless, if the problem occurs for someone else, you might recommend they create a vanilla character inside the game before attempting to use the JavaCC.

Thank you for your attention to this. I appreciate the help.

Now for the difficult part: talking my wife into playing...


November 12, 2017, 08:40:02 AM
Reply #6

I just had a similar problem yesterday. And managed to resolve it with a little bit more specifics.
The problem was in xp2patch.key. You may have it broken... or patched to v1.72. To solve the issue, backup and roll your 1.72 back to 1.69 (dunno about 1.71), and everything will be fine. Just  restore it once you're done creating characters. Hope this helps!