Player Resource Consortium


Author Topic: Need Craft Rod Fix  (Read 1795 times)

0 Members and 1 Guest are viewing this topic.

March 27, 2018, 11:20:20 PM

The Craft Rod feature does not work.
The Craft Rod fix at the following URL: - is corrupt.  Would it be possible to reupload the fix for the Craft Rod feat?

Thank you.

March 28, 2018, 06:21:19 PM
Reply #1

What do you mean when you say it's corrupt? Did you follow the steps and try to add it to the prc_scripts hak?

I checked the .nss file and assume that the problem is that the issue is that it tries to do CICraftCheckCraftWand instead of CICraftCheckCraftRod for rods. If that's all, it would be relatively simple to compile the fixed script.

March 29, 2018, 01:46:31 AM
Reply #2

The download file itself is corrupt.  When I download it, 7zip is getting a data error.  PowerArchiver indicates there are no files in it.

Thank you.

March 29, 2018, 07:36:45 AM
Reply #3

Okay, I tested it and the convo rod crafting did work. The problem wasn't just that it called for the wand function instead of rod, the line was even //'d out.

March 29, 2018, 08:57:34 PM
Reply #4

Thank you very much.  I will try it out this weekend.

April 02, 2018, 09:12:08 PM
Reply #5

Unfortunately, I did not clarify what my bug was with the craft rod feat.  The bug I was having is that I could not add a spell to the rod using the recipe option.  It works with staffs but not rods.  Unfortunately, the attached file does not appear to fix this issue.

Thank you for attaching it though.

April 03, 2018, 07:10:54 AM
Reply #6

Recipe option? You mean the "Examine recipe and craft item"? Afaik that's just a remnant of an old version and doesn't work in general because recipes were removed. At least it doesn't do anything when I try to use it, maybe your module has a custom recipe script?

What I fixed was explicitly the same as that old thread, i.e. the conversation crafting. Now you can use "craft item" on a rod and choose from a list or just cast your spell on the rod to craft it (which worked already).
« Last Edit: April 03, 2018, 08:14:28 AM by Mindflayer »

April 04, 2018, 12:16:44 AM
Reply #7

I didn't realize that.  I'll try that later this week.  Thanks a bunch.

April 04, 2018, 08:41:21 PM
Reply #8

I did a little testing, and I was able to cast a spell directly on the rod.  It worked.  Thank you very much.

August 23, 2018, 07:23:57 PM
Reply #9

Uploaded Mindflayer's fix to SVN.
That is not dead which can eternal lie.
And with strange aeons even death may die.