Player Resource Consortium

 

Author Topic: The Enhanced Edition  (Read 1306 times)

0 Members and 1 Guest are viewing this topic.

March 29, 2018, 06:39:56 PM
  • Adept
  • *
  • Posts: 7
  • Karma: +0/-0
  • New Member
    • View Profile

I can't get the PRC's module updater to recognize the newly released NWN EE, is there some trick? Has anyone managed to get the PRC to work with an EE installation?
Energy Drain is a fun and balanced debuff for the whole family.


March 30, 2018, 05:19:41 AM
Reply #1

Well, i don't think there's a way for the installer to recognize nwn:ee since it has different file structire, registry keys and all that.
One thing you could try to do is manually copy all the required PRC files to your EE installation and use your regular nwn to update EE modules for prc. But then, i don't even know if there even was a change to the official campaigns in EE, you could be able to just copy them over to EE.
Please respon if you have any luck with that.
« Last Edit: March 30, 2018, 05:21:38 AM by Half-Virus »


March 30, 2018, 11:50:54 AM
Reply #2

I haven't tested it but shouldn't the manual installation through the toolset (as described in the manual unter installation) work fine?


March 30, 2018, 12:15:32 PM
Reply #3

Tried installing it. Did not seem to be working, game freezes every time i tried to load a PRC module


March 31, 2018, 08:46:34 AM
Reply #4

If you successfully install it, when you load a modded module put your game in windowed mode before you load it and just let it sit for a moment. It will work. I just posted on steam tat I am the first person to sucessfully do this


March 31, 2018, 02:10:17 PM
Reply #5

Followed your advice, it appears to be working now. Although it takes much more time to load than it was in the diamond edition. Wonder what causes it.


April 03, 2018, 10:25:09 PM
Reply #6

With the announced possible changes, maybe the PRC will get new life.
« Last Edit: April 03, 2018, 10:36:01 PM by sablephoenix »


April 05, 2018, 09:52:42 PM
Reply #7
  • Adept
  • *
  • Posts: 4
  • Karma: +0/-0
  • New Member
    • View Profile

Got the source to compile into the appropriate .haks with the Enhanced Edition. Source is at: https://bitbucket.org/SpitefulBerk/nwn_ee_prc

Beamdog forums discussion: https://forums.beamdog.com/discussion/69913/i-cannot-get-the-prc-to-work-with-ee


April 05, 2018, 11:05:18 PM
Reply #8
  • Adept
  • *
  • Posts: 7
  • Karma: +0/-0
  • New Member
    • View Profile

Got the source to compile into the appropriate .haks with the Enhanced Edition. Source is at: https://bitbucket.org/SpitefulBerk/nwn_ee_prc

Beamdog forums discussion: https://forums.beamdog.com/discussion/69913/i-cannot-get-the-prc-to-work-with-ee

It would be fantastic if the PRC could be updated to make use of new features in the EE such as finally being able to use Bioware spellbooks.
Energy Drain is a fun and balanced debuff for the whole family.


April 06, 2018, 01:06:01 PM
Reply #9
  • Adept
  • *
  • Posts: 4
  • Karma: +0/-0
  • New Member
    • View Profile

It would be fantastic if the PRC could be updated to make use of new features in the EE such as finally being able to use Bioware spellbooks.

Unfortunately I don't think this is a feature in EE yet. A lot of the customization (classes, spells etc) is still work in progress, assuming the progress has already started.


April 19, 2018, 02:29:24 PM
Reply #10
  • Adept
  • *
  • Posts: 4
  • Karma: +0/-0
  • New Member
    • View Profile

So, I've been hacking on this for a while and I'm at a point where I need some testing doing. It would be nice to get some people familiar with the PRC testing it so have some links:

GUI Hak Patcher - http://www.mediafire.com/file/tsz4l1ty4acbzlt/hakpatcher%20EE.7z
EE PRC haks - http://www.mediafire.com/file/hatqataj684laac/PRC%20EE.7z

.net 3.5 is required to run the hak patcher - https://www.microsoft.com/en-us/download/details.aspx?id=21

Note, I've discovered that you can run the PRC in the EE. It only crashes when leaving the character creation window after hitting the class packages bit. You can still create a character here, but your game will crash straight after. You can then reopen the game, load a module/campaign and select the already created character.

Depending on where you installed NWN, you may have to run the patcher as admin. Also, since the character creator hasn't been updated yet, you can't select any new races.


April 20, 2018, 12:33:15 AM
Reply #11
  • Adept
  • *
  • Posts: 7
  • Karma: +0/-0
  • New Member
    • View Profile

So, I've been hacking on this for a while and I'm at a point where I need some testing doing. It would be nice to get some people familiar with the PRC testing it so have some links:

GUI Hak Patcher - http://www.mediafire.com/file/tsz4l1ty4acbzlt/hakpatcher%20EE.7z
EE PRC haks - http://www.mediafire.com/file/hatqataj684laac/PRC%20EE.7z

.net 3.5 is required to run the hak patcher - https://www.microsoft.com/en-us/download/details.aspx?id=21

Note, I've discovered that you can run the PRC in the EE. It only crashes when leaving the character creation window after hitting the class packages bit. You can still create a character here, but your game will crash straight after. You can then reopen the game, load a module/campaign and select the already created character.

Depending on where you installed NWN, you may have to run the patcher as admin. Also, since the character creator hasn't been updated yet, you can't select any new races.

I'll do some testing with Endless Nights.
Energy Drain is a fun and balanced debuff for the whole family.


June 02, 2018, 02:56:54 PM
Reply #12
  • Adept
  • *
  • Posts: 8
  • Karma: +0/-0
  • New Member
    • View Profile

First off: Thank you for your efforts in bringing the PrC to the Enhanced Edition Plok. :)


Just a little heads-up that probably doesn't need saying... but might still help someone else, so why not.

When you install the PrC EE pack, make sure you do not have any files of the original PrC Pack (for old NWN) in your folders from prior experiments.
In my case I only purged the files from erf, hak and tlk, but forgot to delete the files out of database and as a result... the game crahsed on character creation and selection.

Once I deletes those three files, it now works.


Though I have one question: What's with the prc_ocfix? Is it needed for all three original campaigns, only the NWN campaign (but not SoU and HotU) or is it not needed at all?


Edit: I have a confusing issue. Everytime I start a new module, the game apparently created three files in my documents\neverwinter nights\database folder. And if I start another new campaign without deleting those files first, my game crashes in the character creator/selector. Once I delete them again, it works again... any idea what's up with that?
« Last Edit: June 03, 2018, 01:53:26 PM by -Norbert- »


June 29, 2018, 06:28:51 PM
Reply #13
  • Adept
  • *
  • Posts: 8
  • Karma: +0/-0
  • New Member
    • View Profile

I noticed two things with the module updater.
Moduels obtained via the Steam Workshop do now show up. You have to locate the module files in the steam folder and copy them over into the documents\...\modules folder (same for .hak if applicable).

Then I had a further issue. When just trying to update these modules (or any other modules taken from the old NWN) they crashed the patcher... unless they were renamed.
The moment I put an additional letter into the module-file's name (and nothing else) it worked like a charm.

After patching I took the extra letter out and copied the mod files back into the workshop folder, since that seems to override what you have in the documents folder.


July 01, 2018, 11:54:42 PM
Reply #14
  • Adept
  • *
  • Posts: 8
  • Karma: +0/-0
  • New Member
    • View Profile

Hi, apologies for asking what I guess is obvious for many, but everywhere I look there are people saying things about using the PRC in EE that go way over my head in terms of jargon. I can't even tell if getting it working is possible, let alone how. Could someone update me please? If it can be made to work, I'd also really appreciate a dumbed down guide if that's at all possible.

If not I think I'll refund the EE, because I only bought it based on Beamdog's claim that old mods would be compatible.

Thanks, everyone.