Player Resource Consortium

 

Author Topic: PRC Script Compiling  (Read 377 times)

0 Members and 1 Guest are viewing this topic.

February 27, 2017, 02:58:49 AM
  • Adept
  • *
  • Posts: 3
  • Karma: +0/-0
  • New Member
    • View Profile

So I have been trying to wrangle the PRC Pack into an existing PW, and have been having persistent issues with the compiling of scripts.

After initially being unable to compile I switched to the nwtoolset extended. This fixed things until I received this error:

Code: [Select]
2/26/2017 9:53:37 PM: Error. 'afr_onenter' did not compile. prc_inc_castlvl.nss(228): Warning: Number of identifiers exceeds the standard compiler's maximum internal limit (16383); the standard compiler may not be able to compile the script.  Consider removing excess functions, global variables, constants, or structure types. prc_inc_shifting.nss(1563): Error: NSC1047: "const" qualifier not allowed on local variables (see declaration of "CHUNK_SIZE") Compilation aborted with errors.
Since I haven't changed any of the prc includes, and have just been merging the event scripts I presume this is a compiler issue and not one with the scripts. I am not sure what else I can try though. The PRC Script Compiler 2.0 simply crashes my pc on launch.

Anyone have and solutions or suggestions for alternatives?


February 27, 2017, 06:20:14 AM
Reply #1
  • Jr. Associate
  • **
  • Posts: 69
  • Karma: +0/-0
    • View Profile

Xwarren would know if he stumbled on that topic. Have you tried running the PRC script compiler in various compatibility modes, running as an admin and other standard stuff? ;)
Ideas are bulletproof.


February 28, 2017, 02:47:02 AM
Reply #2
  • Adept
  • *
  • Posts: 3
  • Karma: +0/-0
  • New Member
    • View Profile

I was able to get it 'running', but to little avail. It opens, then immediately closes.


March 01, 2017, 05:39:08 AM
Reply #3
  • Adept
  • *
  • Posts: 3
  • Karma: +0/-0
  • New Member
    • View Profile

So I have managed to get to a point to where I can get the compiler to function, but I am still getting the error:

Code: [Select]
Error: NSC1047: "const" qualifier not allowed on local variables (see declaration of "CHUNK_SIZE") Compilation aborted with errors.
it seems to be with the includes primarily. is there an extension or fileset I should have installed for the prc scripts to compile?


March 01, 2017, 11:47:21 PM
Reply #4
  • Developer
  • *****
  • Posts: 1437
  • Karma: +27/-0
  • Gender: Male
    • View Profile

I have searched for 'CHUNK_SIZE' in PRC source code - only found two occurrences and none of them had 'const' qualifier. Which PRC version are you using?

To compile our scripts it is recommended to use nwnnsscomp.exe. It is a command line tool so if you double click on the exe it will do nothing - you need to pass parameters in command line for it to work. Hope this helps ;)